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Introduction  
Whether you design manufactured parts, maps, or buildings, sheets happen! The sheet set 
functionality in AutoCAD enables you to efficiently create, manage, and share your entire set of 
sheets from one convenient location. At first glance, the powerful functionality offered by the Sheet 
Set Manager may seem overwhelming but you don’t have to learn and implement all of the 
functionality simultaneously. You can start by creating a sheet set from your existing drawing 
layouts and then continue to use familiar AutoCAD tools as you implement sheet set functionality 
one step at a time. Although you can implement sheet set functionality in any order, this ten step 
process enables you to progress from the simplest to the most complex functionality with minimal 
disruption to your current workflow. 

You can begin taking advantage of sheet set functionality for your current projects with minimal 
effort by importing your current drawing layouts into a sheet set. From there, you can easily access 
and manage your entire set of drawings. You can continue editing your sheets using traditional 
tools with the convenience of accessing them from a central location. You can open drawings by 
knowing the appropriate sheet name, without having to know the name or location of the drawing 
(DWG) file and you can plot, publish, archive or create an electronic transmittal of the entire set of 
drawings. You can continue creating new drawings using traditional methods and then import 
individual layouts into the sheet set as necessary. Or, you can associate your existing template file 
with the sheet set and create new sheets (drawings) directly from the sheet set manager. Once 
you are comfortable using sheet sets for basic sheet management, you can take your sheet sets to 
the next level by combining Field and Sheet Set functionality. You can create your own fields in the 
form of custom sheet set properties and then reference those, and other fields, in your plot 
stamps, callouts, view labels, and titleblocks.  

This course is divided into three Lessons, enabling you to progress from basic to complex sheet set 
functionality.  

 

 

 

 

Lesson 1

Lesson 2

Lesson 3
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Lesson 1:  Creating and Managing a Sheet Set 
The first step in taking advantage of sheet set functionality is to create a sheet set. You can create 
a sheet set using an example sheet set or by importing existing drawing layouts as sheets. 
Although AutoCAD includes several example sheet sets, it is unlikely that they will meet your 
particular requirements. I suggest that you create your first sheet set by importing drawings from 
one of your existing projects. After you configure your first sheet set to meet your needs, you can 
use it as an example to create future sheet sets. 

1. Review the existing drawing set. 

• Using Windows Explorer, navigate to the Project folder. 

• Notice the folder and file names and structure. 

2. Create a new sheet set using existing drawings. 

• From the File menu, choose New Sheet Set. 

• In the Create Sheet Set wizard, select Existing drawings. 

3. Specify the name and location for the sheet set file. 

• Enter Project A for the sheet set name. 

• Provide a description if you wish. 

• Store the sheet set in the Project folder. 

4. Specify the appropriate import options. 

• Choose Import Options and set the options as 
indicated in Figure 1. 

5. Select the appropriate layouts to import. 

• Choose Browse and navigate to the Drawings folder. 

• Select all of the layouts/folders except the RES folder. 

6. Preview the sheet set and ensure that it matches Figure 2. 

 

Figure 2. 
 

Figure 1. 
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Organize and access sheets 
After your sheet set is created, you can use the Sheet Set Manager to organize and access your 
sheets.  

1. Edit sheet names and numbers. 

• Right-click on a sheet name and choose Rename and 
Renumber. 

• Enter the appropriate names and numbers as indicated in 
Figure 3. You can use the Next and Previous buttons in the 
dialog box to move up and down the sheet list. 

2. Remove a sheet from the sheet set. 

• Right-click on the C-1 sheet and choose Remove Sheet. 

3. Add subsets. 

• Right-click on a subset and choose New Subset. 

• Enter a name for the subset. 

• Choose OK. 

• Repeat the process to create three more subsets: Building 
systems, Electrical, Mechanical. 

4. Remove subsets. 

• Right-click on the first subset you created and choose 
Remove Subset. 

5. Rearrange sheets and subsets. 

• Drag and drop sheets and subsets until your sheet list 
matches Figure 4. 

6. Create Named sheet selections. 

• Select several sheets and/or subsets using the Shift or Ctrl 
keys. 

• From the Sheet Selections drop-down list, choose 
Create. 

• Enter a name for the sheet selection. 

• Repeat the procedure to create sheet two more 
sheet selection sets. 

7. Open drawings in the AutoCAD window by double-clicking on the sheets. 

8. Close all of the drawings without saving changes. 

9. Create a new drawing so that you are not in a zero document state. 

 

 

Figure 3. 

Figure 4. 
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Import existing layouts 
After you have created your sheet set, you can continue to add new 
sheets by importing individual drawing layouts. 

1. Import existing drawing layouts into your sheet set. 

• Right-click on the sheet list and choose Import Layout as 
Sheet 

• Navigate to the Datasets folder and select 8th Floor.dwg. 

• Select the following layouts to import as sheets: Lighting, 
Electrical, Plumbing, HVAC 

• Choose Import Checked. 

2. Rename and rearrange your sheet list to match Figure 5. 

 
Plot using default page setups 
You can easily plot any combination of sheets and subsets or the 
entire sheet set, using the default page setups. 

1. Review the default page setups. 

• Double-click the sheet name to open the drawing. 

• Right-click over a layout and choose Page Setup Manager.           

2. Plot selected sheets. 

• Right-click on a sheet and choose Publish>Publish to Plotter.  

• When the plot completes, review the Plot and Publish Details to verify that the sheet was 
plotted.  

• Repeat the process for multiple sheets, a subset, named sheet selections, or the entire 
sheet set. 

Publish to DWF 
You can easily plot any combination of sheets and subsets or the entire sheet set, to a DWF file. 

1. Review DWF publishing options. 

• Right-click in the sheet list and choose Publish>Sheet Set Publish Options. 

• Set various options and choose OK. 

2. Publish selected sheets. 

• Right-click on a sheet and choose Publish>Publish to DWF. 

• When the plot completes, right-click on the Plot/Publish icon and view the DWF file in the 
DWF Viewer. 

• Repeat the process to publish multiple sheets, a subset, 
named sheet selections, or the entire sheet set. 

• Try the Publish to DWF button at the top of the Sheet Set 
Manager for one-click publishing! 

Figure 5. 
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Create Archive/Transmittal Sets 
You can easily create an archive or transmittal set from any combination of sheets. 

1. Create an Archive set. 

• Close all open sheets without saving changes. If you are in a zero-doc state, create a new, 
blank drawing. 

• Right-click on the sheet set title (Project A) and choose Archive. 

• Specify the archive options and choose OK. 

2. Create a transmittal set. 

• Select any combination of sheets or subsets. 

• Right-click and choose eTransmit. 

• Specify the transmittal options and choose OK. 

Lesson 2:  Assigning Sheet Set Properties 
You can take your sheet sets to the next level, enabling you to work more efficiently, by 
customizing the sheet set properties. Continue using the sheet set you created in Lesson 1 or use 
the sheet set located in the 02Project folder. 

1. Assign a page setup file to the sheet set. 

• Right-click on the sheet set title and choose Properties. 

• For the Page Setup Overrides File, navigate to the Project folder and select Project 
Template.dwt. 

2. Assign sheet creation properties to the sheet set. 

• For the Sheet Creation Template, navigate to the Project folder and select Project 
Template.dwt. 

• For the Sheet Storage Location, navigate to the Project/drawings folder. 

3. Assign a label block to the sheet set in preparation for Lesson 3. 

• For the Label Block for Views, navigate to the Project folder and select Project 
Template.dwt. 

• Select the option to Choose blocks in the drawing file and choose the View Label block. 

4. Assign callout blocks to the sheet set in preparation for Lesson 3. 

• For the Callout Blocks, choose Add and then navigate to the Project folder and select Project 
Template.dwt. 

• Select the option to Choose blocks in the drawing file and choose the Callout Bubble. 

5. Assign a resource drawing location to the sheet set in preparation for Lesson 3. 

• For the Resource Drawing Locations, navigate to the Drawings/Architectural/Res folder. 

• Choose OK to close the Sheet Set Properties. 

Notice that you can assign a sheet creation template and drawing storage location based on 
the subset. 
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Plot using any page setup 
You can create named page setups on the fly and use them to override the default page setups 
that are saved in the drawing layouts. 

1. Plot using page setup overrides. 

• Right-click on the sheet set title or any sheet or subset and choose Publish>Publish Using 
Page Setup Override. Notice the page setup options. 

2. Create new page setups.  

• Right-click on the sheet set title or 
any sheet or subset and choose 
Publish>Manage Page Setups. 

• Create several new page setups: 

LaserJet   (ANSI A(8.5x11), 
Extents, Fit to paper) 

DesignJet (Arch D(36x24), Layout, 
1:1) 

Note: Since you don’t have these 
devices installed, you can “pretend” by selecting DWF6 as the device. 

• Close the Page Setup Manager 

3. Verify access to your new page setups. 

• Right-click on the sheet set title or any sheet or subset and choose Publish>Publish Using 
Page Setup Override. Notice the new page setup options. 

Create new sheets 
1. Create a new “blank” sheet in the sheet set. 

• Right-click in the sheet list and choose New Sheet. 

• Enter a sheet number and name. Notice the file name, folder path, and sheet template. 

2. Open the newly created sheet. 

• Double-click on the new sheet 

• Review the titleblock data. 

3. Close the new drawing and remove the sheet from the sheet set. 
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Lesson 3: Utilizing Fields 

The Sheet Set Manager enables you to define custom properties to use as fields for the entire sheet 
set or for individual sheets. For example, you might create custom properties for the project name 
and number, whose values apply to the entire sheet set. And, you might create custom properties 
indicating who drew or reviewed a particular sheet, in which case the properties are owned by each 
sheet. The custom properties you create are available as fields in your drawings. 

Continue using the sheet set you created in Lesson 2 or use the sheet set located in the 03Project folder. 

1. Create custom sheet set properties. 

• In the Sheet Set Manager, right-click over the sheet set title and choose Properties. 

• In the Properties window, choose Edit Custom Properties. 

• Choose Add to create the custom properties as indicated in Figure 6. 

 
Figure 6. 

 

Process Overview: Automating Plot Stamp Data 
In AutoCAD, you can combine field functionality with familiar Mtext editing to create a plot stamp 
that is as flexible in appearance and location as any other piece of text. Since the plot stamp is 
actually an Mtext object, you can view and modify its appearance in an intuitive WYSIWYG 
environment without having to first plot the drawing. You can create the plot stamp in your 
drawing template so that it is automatically included in any new drawings that you create. The field 
values automatically update to display data based on the new drawing. You can even copy the plot 
stamp into an existing drawing with the assurance that the field data will update accordingly.  

The following procedure describes how to use fields to create a plot stamp. You can use this 
procedure regardless of whether you are working with individual drawings or sheet sets. 

1. In AutoCAD, open the drawing (DWG) or template (DWT) that you use for creating new sheets. 

2. Create a new Mtext object. 

3. In the Mtext editor create any labels that you want to include in your plot stamp. For example, 
you might want a label for the plot date, drawing file name, and who plotted the drawing. 
Creating labels is optional. You may choose to insert field data without preceding text.  

4. After each label, right-click in the Mtext editor and choose Insert Field.  

5. In the Field dialog box, select a field category and a field name. 

The field category and field name that you choose depends on the data that you want to 
display. The drawing file name field is in the Documents field category but all of the plot-
specific fields are in the Plot field category. If you want to display the plot date, for example, 
select the Plot field category and the PlotDate field name. Depending on the field that you 
choose, you may have the option to select from various formats such as month/day/year or 
year-month-day.  
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When you exit the Field dialog box, the field value appears in the Mtext editor. If the field 
cannot be evaluated, it will display dashes “----“. For example, AutoCAD can’t evaluate the 
PlotDate field until the drawing is actually plotted. After you insert your fields in an Mtext 
object, you can modify their appearance using typical editing features. You can change a field 
by double-clicking on it and choosing an alternate one from the Field dialog box. 

 

After you create your plot stamp, you should verify that all of the fields function properly. The 
fields that you included in your plot stamp will determine how you should test it. The following 
procedure describes how you might test the fields for PlotDate, FileName, and Login. 

1. Log out of Windows and login using a different name (or send your template to a different user 
to test). 

2. In AutoCAD, create a new drawing based on your template. 

3. Plot the new drawing. 

4. You can plot to a DWF file to save paper and eliminate the need for a hardcopy device. 

5. Verify that the plot data, file name, and login name updated appropriately. 

6. The plot date in the drawing displays the last plot date. This value will remain in the drawing 
until the next time the file is plotted. 

 

Automate plotstamp data 
1. Open the sheet creation template. 

• Verify the name and location of the sheet creation template in the Sheet Set Properties 

• From the File menu, choose Open and navigate to the template file. 

2. Create an Mtext object. 

• From the Draw menu, choose Text>Multi-line Text. 

• Place the Mtext object and enter text similar to Figure 7. 

 
Figure 7. 

 

3. Add fields to the Mtext object. 

• Click in the space after Filename: 

• Right-click and choose Insert Field. 

• Select the Filename field and choose OK. 

• Repeat the process for each of the fields as indicated in Figure 8: PlotDate, DeviceName, 
PageSetupName, Login. 

 
Figure 8. 
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Process Overview: Automating Label and Callout Data 
Most sets of drawings contain information that is interrelated. For example, a view on one sheet 
might refer to a view on a different sheet. Using traditional methods, you can manually maintain 
the text references between sheets but that process can be tedious and error-prone. You can 
dramatically improve your productivity and drawing accuracy by updating your existing callout and 
view label blocks to include fields. With field-enabled callouts and view labels, not only is the 
textual data dynamically updated as changes occur, hyperlinks enable you to open the sheet, which 
is being referred to, and automatically zoom to the appropriate location. Sheet set functionality 
enables you to create links between callouts and views throughout the entire sheet set.  

A sheet set may reference one label block and any number of callout blocks. The label and callout 
blocks can point to block definitions within a drawing (DWG) or template (DWT) or they can point 
to individual drawing or template files. Even before you 
customize your callout and label blocks with fields, you can 
begin using them with your sheet sets. If you associate your 
label block with a sheet set, it will automatically insert when 
you place a new sheet view.  

1. In the SSM, right-click over the sheet set title and choose Properties. 

2. In the Sheet Set Properties dialog box, for the Label Block for Views property, navigate to the 
drawing (DWG) or template (DWT) where the label is stored. 

3. In the Select Block dialog box, select the Drawing File as a Block if the drawing or template 
itself is the label block. Or, select Blocks in the Drawing File if the label is stored as a block 
definition within the drawing or template and then select the appropriate block definition. 

4. In the Sheet Set Properties dialog box, for the Callout Blocks property, navigate to the drawing 
(DWG) or template (DWT) where the callouts are stored. 

5. In the Select Block dialog box, select the Drawing File as a Block if the callouts are stored in an 
individual drawings or templates. Or, select Blocks in the Drawing File if the callouts are stored 
as a block definition within the drawing or template and then select the block definition to use. 

In some cases, you may wish to use different callout blocks for different types of views. For 
example, you might have a view category called Elevations that points to one set of callout blocks 
and a view category called Sections that points to a different set of callout blocks. You can use the 
View List tab of the sheet set manager to assign callout blocks to different view categories.  

1. In the SSM, select the View List tab.  

2. Choose the View by Category icon. 

3. Right-click on the sheet set title and choose New View Category. 

4. In the View Category dialog box, choose Add Blocks. 

5. In the List of Blocks dialog box, choose Add and navigate to the drawing (DWG) or template 
(DWT) where the callouts are stored. 

6. In the Select Block dialog box, select the Drawing File as a Block if the callouts are stored in an 
individual drawings or templates. Or, select Blocks in the Drawing File if the callouts are stored 
as a block definition within the drawing or template and then select the block definition to use. 

If your callout and label blocks do not contain attribute definitions, you can define block attributes 
using traditional methods and then insert fields in the Value box. Assuming that your blocks 
already contain attribute definitions, you will need to modify the attribute definitions to utilize 
SheetSetPlaceholder fields. 

1. From the Modify menu, select Object>Attribute>Block Attribute Manager 
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2. In the Block Attribute Manager: 

• Select a callout block. 

• Double-click on one of the attributes that requires a field (such as view number, sheet 
number, or viewport scale). 

3. In the Edit Attribute dialog box: 

• Select Preset mode. 

• Right-click in the Default value box and choose Insert Field. 

• In the Field dialog box, under Field category, select SheetSet and under Field names, select 
SheetSetPlaceholder. 

• Under Placeholder type, select the appropriate option and if applicable, select Associate 
Hyperlink and then apply the changes. 

Using the SheetSetPlaceholder fields in your callout and label blocks enables you to define block 
attributes for fields that are not associated with any particular sheet or sheet set. The placeholder 
field that you select depends on the data you want displayed for the attribute you are currently 
editing. Common placeholder fields include:  

ViewNumber to display the number of the view 
for which the callout or label is referring. 

SheetNumber to display the number of the 
sheet for which the callout or label is referring. 

ViewportScale to display the scale of the 
viewport for which the label is referring. 

The Associate Hyperlink option is available for 
view and sheet numbers and titles and is most 
commonly used for creating callout blocks. If you 
associate hyperlinks with your callout blocks, you 
can click on the callout in one sheet and AutoCAD 
will automatically open the associated sheet and 
zoom to the proper view. 

Once you have updated your label and callout blocks to include fields, you are ready to test them! 

1. In the Sheet Set Manager, right-click on the sheet set and choose New Sheet.  

2. In the New Sheet dialog box, enter a sheet number and title. 

3. In the Sheet Set Manager: 

• Double-click on new sheet to open it.  

• Select the Resource Drawings tab. 

• Navigate to a drawing that contains modelspace views. 

• Drag and drop the drawing or modelspace view within the drawing to the new sheet. 

The label block referenced in the sheet set properties is automatically placed on the 
drawing. Review the label data to ensure that it displays the correct values. By default the 
view number displays as dashes “----“. You must renumber the new sheet view to assign it 
a value. 
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4. In the Sheet Set Manager: 

• Choose the View List tab and select the newly created sheet view. 

• Right-click over the view name and select Rename & Renumber. 

• Make changes to view number and view name. 

5. Regenerate the sheet to ensure the values update accordingly. 

6. In the Sheet Set Manager: 

• Double-click on a different sheet to open it in the drawing editor. 

• Select the View List tab 

• Right-click over the view name and select Place Callout Block. 

• Select one of your callout blocks and place it on the sheet.  

Review the callout data to ensure that it displays the correct values. You should repeat this 
process for each of your callout blocks. 

Tip: If you are using a Dynamic Block (introduced in AutoCAD 2006) to combine all of your 
callouts into a single block definition, you only have to do this procedure once! 

 
Automate sheet and view data 
You can automate the process of inserting callout and label blocks by associating them with the 
sheet set (as you did in Lesson 2), but to fully automate the process of placing views and 
referencing them with callouts, you must add fields to the blocks. Fields, specifically 
SheetSetPlaceholder fields, enable you to define callout and label blocks that reference “future” 
data. For example, you can create a label block with a placeholder field for the viewport scale. 
What viewport? You don’t know yet. That is why it is a placeholder!  

1. Add fields to the Label block. 

• Open the sheet creation template file. 

• Insert and explode the View Label and the Callout Bubble blocks. You can also use 
BATTMAN to edit the block definition. 

2. Replace the default attribute values with fields. 

• Double-click on the attribute (or use BATTMAN) 

• Right-click in the Default box and choose Insert Field.   

All the fields for callout and label blocks can be found in the SheetSet field category and the 
SheetSetPlaceholder field name. For the fields in the callout block, select the Associate 
Hyperlink option. It is not necessary to associate a hyperlink with the fields for the view 
label. Repeat this procedure on the remaining callout blocks. 

 

3. Override the old label block definition. 

• Erase the insertions of the blocks. 

• Save the drawing template file. 
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Process Overview: Automating Titleblock Data 
AutoCAD offers considerable flexibility in the way you create and edit your titleblocks. For example, 
you might attach your titleblock as an external reference but store the titleblock data as text within 
each drawing. Alternatively, you might insert your titleblock in a template file and then edit 
titleblock attributes each time you create a new drawing from the template. Regardless of how you 
create and use your drawing titleblocks, you can significantly automate the process of updating 
titleblock data by utilizing fields. The field functionality in AutoCAD enables you to include sheet set 
data in your drawing titleblocks so that, as sheet and sheet set information changes, the title block 
data is always current. To automate your titleblock data, you must replace the existing data with 
field codes. You can insert field codes using the Field dialog box that is accessible in most text and 
attribute editing tools. The Field dialog box includes field codes for common data such as current 
date, sheet number, and drawing name. In addition to using the predefined field codes, you can 
create your own fields for a sheet set and then access them from the Field dialog box. 

The following procedures assume that your titleblock is inserted on a layout of a template drawing 
and that the titleblock contains attribute definitions. Even if your situation differs slightly, you can 
apply the general ideas that are included in these procedures. 

1. In the Sheet Set Manager, right-click on the sheet set title and choose Properties. 

2. In the Sheet Set Properties dialog box, choose Edit Custom Properties. 

3. In the Custom Properties dialog box, choose Add. 

4. In the Add Custom Property dialog box: 

• Enter a name for the property. 

• Enter a default value for the property. 

• Specify if the property is owned by the entire sheet set or on a sheet-by-sheet basis.  

The custom properties that you define in the Sheet Set Manager are available as sheet set fields in 
the Fields dialog box.  

If your title block is inserted in a template file, your first instinct might be to open the template file 
and edit the titleblock from there. Although this method will work, it does not offer you instant 
feedback as you select various sheet set fields because the template file itself is not a sheet in the 
sheet set. The easiest way to add fields to your titleblock, with the assurance that you are selecting 
the proper fields, is to work with it as part of the sheet set. You will create a new sheet that is 
based on your standard template file. To do this, you must have access to a sheet set. You can use 
any existing sheet set and then, after you update the titleblock to include fields, you can remove 
the titleblock sheet from the sheet set. If you have multiple sheet sets to choose from, consider 
using a sheet set that utilizes custom sheet set properties and a sheet creation template that us 
appropriate for the majority of your projects. 

You can use the Sheet Set Manager (SSM) to view or edit the sheet creation template and custom 
properties associated with your sheet set. 

1. In the SSM, right-click over the sheet set title and choose Properties. 

2. In the Sheet Set Properties dialog box: 

• Verify (or select) the sheet creation template file (DWT, DWT, or DWS) and layout 
containing the titleblock. 

• Verify (or create) custom sheet set properties. 
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3. In the SSM, right-click over the sheet set title and choose New Sheet. 

4. In the New Sheet dialog box, enter values for the sheet number and title.  

Tip: Use values that are easily recognizable when assigning field codes, such as “SheetNum” 
and "SheetTitle". 

5. In the SSM, double-click on the new sheet to open it in the drawing editor. 

After you create a new sheet, which is identical to the template file containing your titleblock, you 
can easily replace the default attribute values with field codes. Any titleblock data that worked well 
as an attribute is a good candidate for using fields. When editing attribute definitions, you might be 
tempted to use REFEDIT or BATTMAN. Although these methods enable you to redefine the attribute 
definitions, they do not update attribute values of existing block insertions. If you choose to use 
REFEDIT or BATTMAN to add fields, you must erase the current instance of the titleblock and 
reinsert the updated block. To simplify the editing process and remove any uncertainty caused by 
existing block instances, I strongly recommend that you explode the titleblock, making note of its 
insertion point. You will see all of the attribute tags and you can double-click on them for easy 
editing.  

1. Select the titleblock.  

2. From the Modify menu, choose Explode. 

3. Double-click on an old (non-field) attribute. 

4. In the Edit Attribute Definition dialog box, right-click in the Default value box and choose Insert 
Field. 

5. In the Field dialog box, select a field category and a field name. 

The field category and name that you choose depends on the attribute you are currently editing. 
For example, if you want the attribute to display the current date, you would select the Date & 
Time field category and the Date field name. Most of the fields that you will use for titleblock data 
are in the SheetSet field category and the field names begin with “CurrentSheet”.  Using the 
CurrentSheet fields in your titleblock enables AutoCAD to read the values that apply to any sheet in 
which the titleblock is inserted. For example, you will probably want attributes that display the 
CurrentSheetNumber and CurrentSheetTitle.  

If you created custom sheet set properties, you can access them using the CurrentSheetSetCustom 
and CurrentSheetCustom field names. Of these two custom options, the one you select depends if 
the custom property you created is owned by the sheet set or by the sheet. A drop-down list 
enables you to see all of the available custom properties. For example, if you created a custom 
sheet set property called Project Name, which is owned by the sheet set, you would select the 
CurrentSheetSetCustom field name and then select Project Name from the Current Property Name 
list. 

As you apply fields to your attribute definitions, you receive instant feedback by seeing the 
appropriate value displayed in the Edit Attribute Definition dialog box. If you do not see a value, 
the sheet set property has not been assigned a default value. You might find it helpful to include 
generic default values for all of your sheet set properties. For example, in the Description property 
for a sheet, enter the words “Sheet Description”. The instant feedback that you receive during the 
field insertion process is the only reason that I suggest updating the titleblock drawing as part of a 
sheet set rather than editing the template file directly. If you opened the template file without it 
being part of the sheet set, you would receive no feedback regarding sheet set properties and 
because it would have no current sheet set to read from, the list of custom property names would 
be blank requiring you to remember the custom property names rather than selecting them from a 
list. 



 Ten Steps to Make Sheets Happen! 

 

   15 

After you update all of the titleblock data, you must remove the titleblock drawing from the sheet 
set and use it to replace the old sheet creation template.  

1. In the SSM, right-click on the sheet you have been working on and choose Remove Sheet. 

The drawing is still open but it no longer belongs to the sheet set. 

2. From the File menu, choose Saveas. 

3. In the Save Drawing As dialog box, select the appropriate file type (DWT, DWG, or DWS), and 
select the sheet creation template file to overwrite.  

Tip: Prior to saving the file, it is a good idea to verify the file name and path of the sheet 
creation template in the Sheet Set Properties to ensure that the one you overwrite is the same 
one that is being used by the sheet set. 

4. From the Draw menu, choose Block>Make. 

5. In the Block Definition dialog box, select the name of the titleblock block definition. 

6. Select all of the objects to include in the block definition. 

7. Specify the basepoint for inserting the titleblock. Hopefully you took note of the previous 
insertion point prior to exploding the block. 

Because you redefined the titlblock after removing the sheet and resaving the drawing, there are 
no current sheet set values associated with this template drawing and all of the current sheet set 
fields display with # symbols. If you redefine the block prior to removing the drawing from the 
sheet set, the attributes will maintain the last evaluated field values. This could be helpful 
depending on the default field values that you chose. For example, if the current sheet number was 
“SheetNum” as suggested, it might be helpful to see that text displayed in your titleblock (as 
opposed to seeing ###).  If, on the other hand, the current sheet number was “01”, it would be 
confusing to see that irrelevant text displayed in your titleblock. 

After you replace your previous titleblock template with your new version, you should verify that all 
of the titlebock fields function properly. You can do this by creating a new sheet using your new 
template and then reviewing and editing the associated titleblock data. 

1. In the Sheet Set Manager, right-click on the sheet set and choose New Sheet. 

2. In the New Sheet dialog box, enter a sheet number and title. 

3. In the Sheet Set Manager, double-click on new sheet to open it.  

4. Verify the titleblock data to ensure that it displays the correct values. 

5. Make changes to sheet and sheet set values and then regenerate the new sheet to ensure the 
values update accordingly. 

Once you have verified that your titleblock data updates appropriately you are good to go! New 
sheets that you create using your titleblock will automatically display the current sheet information 
and, with little effort, you can replace the titleblocks in the existing drawing layouts that you 
imported. Simply erase and purge the old titleblock definition from existing drawings and insert the 
new titleblock. You don’t have to reenter the attribute data because it is still stored with the sheet 
set and automatically read by the titleblock fields. 
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Automate titleblock data 
1. Edit a copy of the sheet creation template. 

• Create a new sheet in the sheet set using SHEETNUM and SHEETNAME for the number and 
title. 

• Open the new sheet and explode the titleblock. Do not double-click or use REFEDIT or 
BATTMAN. 

2. Replace the default attribute values with Fields. 

• Double-click the attribute. 

• Right-click in the Default box and choose Insert Field. 

• Select the field as indicated in Figure 9. 

 

 

Figure 9. 
3. Remove the SHEETNUM SHEETNAME sheet from the sheet set. 

4. Reblock the TitleBlock using 0,0 as the insertion point. 

5. Replace the old sheet creation template with the new one. 

• Verify the name and location of the current sheet creation template in the Sheet Set 
Properties. 

• Use SaveAs to overwrite the previous version of the sheet creation template. 

 

With the Sheet Set Manager and field functionality, you will save time and reduce errors. You can 
let AutoCAD update text references between views and sheets while you focus on your design! 

Field Category: SheetSet 

Field Name: CurrentSheetSetCustom 

Field Category: SheetSet 

Field Name: CurrentSheetTitle 

Field Category: SheetSet 

Field Name: CurrentSheetNumber 

“OF” 

Field Category: SheetSet 

Field Name: CurrentSheetSetCustom 
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Field Name: CurrentSheetCustom 
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