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View from the Upper Deck (Overview of Fields) 

 

You will learn the following Field topics during this lesson: 
• Creating more intelligent drawings using Fields 

• Where to use Fields 

• The basics of Fields 

• Advanced Field tools 

 

 

An overview About Fields: 

Fields first became available in AutoCAD 2005. They are a part of other text 
including: mtext, dtext, attributes and tables. You can tell field text from other text 
because fields will display as highlighted with a gray background. 

You use Fields because they can: 

• Provide automatic text labeling. 

• Evaluate other information. 

• Link information dynamically that can automatically update. 

• Provide tools that would otherwise, not be easily available through for the 
average user. 

• Retrieve information from associated drawing files 

• Update when you open, Save, plot, eTransmit or Regen. 

• Use intelligent data, commonly referred to as metadata 

 
Metadata: The term is often used to indicate data, which refers to digital 
data about digital files. This may include file size, location, file properties 
information etc. 

 

 

 

 

A Field is an intelligent piece of text information. 

 

Field Definition:  Fields are “specialized text objects set up to display data that 
may change during the lifecycle of the drawing. When a Field is updated the latest 
value of the Field is displayed.”   From Autodesk online help, AutoCAD 2006   

 

 



 

4

Exercise 1: Fields and Metadata 
 

 

Objective of exercise: To provide basic 
concepts of Field and metadata use.  

Estimated time: 5 minutes     
 

 

1. Open “C:\datasets\GD12-1L1-
Circle.dwg”   

2. Zoom in to the lower right hand corner 
to see titleblock text. 

3. Click File>Drawing Properties to open the “Drawing Properties” dialog box. 

4. Click the Summary tab 

5. In the Author value box, add your name. 

6. Click OK to close the “Drawing Properties” dialog box. 

7. Click View > Regen  (command line: RE) 

Notice:  The information in the titleblock updated after the Regen. 
 

8. Click the Model tab 

9. Left click to select on the circle. The circle is highlighted and the grips are 
displayed. 

10. Left click on a grip on the circumference to make it red. This is called a Hot 
grip. 

11. At the command line type 8.5 and press the Enter key.  

The circle radius is now 8.5 units.  
 

12. Click View > Regen  (command line: RE) or Save to update Fields. 

13. Save the file.  

End of exercise 
 

Bonus Steps  
14. Repeat steps 10 – 13 using your own circle size. 

15. Click on the ellipse and rectangle to modify their shapes and sizes. Regen. 

16. Go back to the layout and make additional changes to the File > Drawing 
Properties.   

17. Save the file as a new name to see the file name path update.  

18. Make additional changes and use the Regen or Save to update the Fields. 
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Scouting for Fields (Where to find Fields) 
Fields are text objects. Therefore, where you find text, in many cases you can 

find Fields. You can access Fields directly through the pull down menu 
(INSERT>FIELD). 

 
Command Access: 

 
 

 

 

You can right Mouse Click in most text editing tools. Some object types that support 
Fields include:  Multiline text, Dtext, Attributes, and Tables. 

 

Properties of fields in the Field dialog box: 

• Each Field can have it’s own unique selection of formats to select from. 

• In the Field dialog box, a preview of the Field will be shown above the 
selection or formatting options. 

• A Field expression showing how the Field is created is shown below the 
Field names. 

 
Players Stats (What information a Field can provide) 

You can select from multiple of different categories for your Field information. 
The types of data are separated by Field category. Select ALL to display all 

categories. Each category has Field names to select from. After a Field name has 
been selected the right side of the dialog will let you further define the Field or set 
formatting. 

Date and time: 

 

 

 

Document: 

 

 

 

 

 

 

Linked:  

 

Objects: 

 

 

Other: 

 

 

 

Plot: 

 

 

 

 

 

Sheet Sets: 

 

 

 

 

 

 

 

 

Pull down menu: Insert>Field 

Command line:  FIELD 
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Exercise 2: Inserting Fields 
 

Objective of exercise: Learning how 
to access Fields  

Estimated time: 5 minutes     

 

 

(Note: RMC = Right Mouse Click) 

1. Close any files you may have open 
from previous exercises. 

2. Open C:\DATASETS\GD12-1L \2-
FIELD_TEXT.dwg 

3. Click Insert > Field from the pull-
down menu bar. 

4. Under the Field Category; Click 
“Document” 

5. In Field names; Click “Filename.” 

6. Under Format; Click “Title case” 

7. At the far right of the dialog box, toggle between: 

• Filename only 

• Path only 

• Path and filename 

Notice the gray Field value box change as you modify your selection 
8. Uncheck “Display file extension” 

9. Click OK and place in the lower left corner of the drawing. 

End of exercise 
 
Bonus 

10. Click Insert > Field from the pull-down menu bar.  
• In “Field Category” Click Document 
• In “Field names” Click “Filesize.”   
• Under Format Click “Bytes” 

11. Click OK. 
12. Place in the lower left corner of the drawing.  
13. Repeat steps 10 – 11 using Kilobytes and Megabytes. 
14. Use Regen or Save to update Fields. 
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Who’s on first? (What Fields to use and where) 
Who are the team players? (categories of Fields) 

One of the tricks when setting up Fields is determining which Fields to use and where to use them. 
This list is to get you started on ideas for Field use and not meant to limit you.  

Date and Time brings in information from dates and times as they relate to the digital AutoCAD 
file. “CreateDate” and “Date” are static. The Plot and Save dates are dynamic meaning that they 
will update to a new value each time the file is Saved of plotted. “Date and time” offers the most 
formatting options and is the only Field that will let you further modify the formatting and provide 
hints on how to format.  Possible use: Use “Date” to bring in the calendar date in titleblock. Include 
Plot and Saved dates outside the border or on no-plot layers for internal information. 

Document: General document properties including file size and location. Drawing properties 
information is added in the Drawing Properties dialog box.  Possible use: Populating information in 
title blocks that will update on multiple layouts. Custom properties can be added for use in tables 
and charts. Using Fields in the titleblocks to narrow the search for titleblock information through 
the Design Center. Note: MS search can find text in the drawing but does not sort how the text is 
associated to the drawing. 

Linked: Hyperlink; will link the text to another document, to a layout tab within your drawing to 
web pages and to e-mail.  Possible use: Add a text label linking to details in model space to the 
corresponding layouts. Include links to your companies’ web page.  Link to initiate sending emails. 
Link to the suppliers web page for detail or pricing on purchased parts. Link to your customer web 
pages. Link to MSDS (Material Data Safety Sheets). Link to any relative information.  

Objects:  “NamedObject” will allow you to select from named objects, many of which you would 
find listed in the Rename command such as blocks, dimension styles, layers, views, etc.  “Object” 
includes drawing objects such as line, arcs and circles. The properties of the drawings objects can 
be listed in a Field. As the object changes or names objects are renamed, the Field’s will update.  
Possible use: Listing area or perimeter of a room. List the size of a doorway. Listing block names in 
the drawing or in tables. Listing the scale of a viewport.   

Other: “SystemVariable” includes all of the system and drawing variable settings. “DIESEL 
expression” DIESEL is a macro language that can be used.  Possible use: Include system variable 
settings in the titleblock. Insert a predefined text block for drawing checking. Include additional 
information in custom plot stamps such as the system variables CTAB (name of current tab) and 
PLOTOFFSET.  

Plot: includes information that is related to plotting. Many of these are system variables that you 
could search for in the “Other” category.  Possible use: Create a custom Plot stamp.  

Sheet Sets: Field information that is used in sheet sets. The intelligence of sheet sets is largely 
built on an involved use of Fields.  Possible use: designed for use is sheet sets. Custom callout 
blocks and label blocks. 
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Running the Bases  (Text Tools That Support Fields) 
Examine the different tools that support Fields and how to access Fields from each of 

them.  

 

Field: (When accessed through the Insert > Field menu or type FIELD at the command line.) Fields 
inserted though the Field command will be inserted as an mtext object. The Field command will 
directly open the Fields dialog box. The Field size will be predetermined by the system 
variableTEXTSIZE.  

 

Mtext: Access Fields with Ctrl+F or RMC 
(Right mouse click) in the text editing 
box and Click “Insert Field...”  

 

Dtext: During original placement of 
Dtext, RMC on the graphics screen and 
Click “Insert Field.” During editing of 
existing dtext, RMC in the text editing 
box and Click “Insert Field...”  

 

Attributes: When creating Attributes, select the “Insert 
Field...” button or RMC in the value box and Click “Insert 
Field…” 

 

Inserting or editing blocks with attributes:  In the associated dialog boxes, RMC and Click 
“Insert Field...”   

 

Tables: double click in cells to access the Mtext editor. Once in the text editor, access Fields with 
Ctrl+F or RMC in the text editing box and Click “Insert Field...” 

 

Tables were new in AutoCAD 2005. Like Microsoft excel tables, a table is made of a title, 
rows and columns and can hold text and graphics. 
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Exercise 3: Accessing Fields 

 

Objective of exercise: Learning how to access Fields within multiple text tools. 

Estimated time: 5 minutes    (Note: RMC = Right Mouse Click) 

 

1. Open C:\DATASETS\GD12-1L \3-FIELD_TEXT.dwg  

2. Type ATTDIA. Type 1 and press Enter.   

3. Start the insert command (command line: INSERT or I) 
4. Insert a block with attributes using the following information:  

a. Block name: SAMPLE BLOCK.  

i. Insertion Point: x = 4, y = 6, z = 0 

ii. Scale = 1,  Rotation = 0 

iii. Click OK.  The Edit Attributes dialog box opens 

b. In the ENTER LOGIN NAME box RMC (Right Mouse Click) in the value area and click 
Insert Field. Enter the following settings: 

i. Field category:  Plot  

ii. Field names:  Login. 

iii. Format:  lowercase  

c. Leave the attribute “key words” blank. 

d. Click OK to close Fields dialog box 

End of exercise 
Bonus 

5. Double click on each of the following items to open the associated editors. RMC in the editor 
to see the “Insert Field…” option. Insert the Field and set the category, Fieldname and 
format as listed in the following chart: 

 
TEXT in DWG to 

Modify FIELD CATEGORY FIELD NAME FORMAT 

Sample of Block/ 
"Key words"  Document Keywords Titlecase 

“Sample of Mtext” Other SystemVariable ctab 

“Sample of Dtext” Plot Papersize Uppercase 

Table cell/ cell A: Date & Time CreateDate M/d/yyyy h:mm:ss tt 

Table cell/ cell B: Date & Time Date M/d/yyyy h:mm:ss tt 

Table cell/ cell C: Date & Time SaveDate M/d/yyyy h:mm:ss tt 
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Rookie Season (The Basics of Fields) 
Getting the basics down. Looking at how to edit, and update Fields.  

Pinch hitting  (Editing Fields) 

Editing the Field text by accessing the associated text editor. RMC in the associated text edit box 
and Click “Edit Field.” You can change to a different format, filed name, or category. To modify the 
values displayed in the Fields you can change the information that is being read such as the 
Drawing Properties, and then; update the Field.  

The Scoreboard (Updating Fields) 

An updated Field will show the latest value. There is no visual indicator to let you know if the Field 
is updated or showing the latest information. 

Fields can be updated individually by RMC in the associated text edit box and Click  “Update Field.” 
Type UPDATEFIELD and select the desired Field to update. UPDATEFIELD will update all the Fields 
within a selected Block or Table. 

Fields will automatically globally update 
when you do any of the following: Open, 
Save, Plot, Regenerate, or send with an 
eTransmit.  

Note: The Field “Date” inserted from the 
category “Date & Time,” will not 
automatically update but must be manually 
updated. 

Control the automatic update settings in 
Options on the “User Preferences” tab, 
“Field Update Settings.” (System variable 
with FIELDEVAL.)  

Grounds Keeper (Fields appearance) 

Fields are displayed with a light gray background. The background will not plot. The background of 
the Field can be turned off in the graphics screen so that Fields look like other text. When the 
background is turned off, it will not display on the graphics screen; however, it will still display in 
the text editors. You control the background in Options on the “User Preferences” tab.” (System 
variable with FIELDDISPLAY.)  

• A Field that displays as four dashes,  ----, the Field has been defined but is currently empty.  

• A Field that displays as four pound symbols,  ####, the Field definition cannot be found, 
information about the Field in not available or invalid. 

Cleats (When FIELDS are stopped in their tracks) 

There are some tools that will not support Fields and will stop you dead in your tracks. Examples of 
these un-supported tools include:  

• Plot Stamp: the default plot stamp. 

• Express tools; arc aligned text and rtext. 

• Spell check: Since a Field is reading the information from another location spell check won’t 
work.  
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Away Games  (Fields in unsupported environments) 

When Fields enter an environment that they are not supported in, they will temporarily look like 
any other text and display their last known information. Field information will not be updated while 
it is in the unsupported version. Fields will round trip to pre 2005 releases or to an LT version and 
come back undamaged as long as the Fields are not edited or deleted.  

• Round trip: A drawing that is Saved to an earlier release of AutoCAD, which doesn’t 
support Fields, will have the Field text temporarily changed to normal text. When the 
drawing returns to the 2005 or 2006 AutoCAD version, the Field will return.  

• Unsupported releases: Fields are not supported in any version of LT or in any release of 
AutoCAD prior to 2005. 

 

Sent to the Minors (Convert Field text to normal text)  

If you change the formatting, it can result in permanent 
loose of Field intelligence. When the Field intelligence is lost, 
the last displayed Field information, will be displayed in the 
text object. You would have to manually edited the text t o 
regain Field intelligence. In AutoCAD 2006 you can define a 
block to not be exploded to discourage used from converting 
field text to regular text. You can accomplish the same thing 
in earlier releases; you can use MINSERT to insert a block 
that cannot be exploded. You would then set rows and 
columns to a value of 1.   

Ways you can send Fields to the minor league. 

• Edited in earlier releases: Fields edited in earlier 
releases will remain as regular text. 

• Exported Tables: When AutoCAD Table information 
that is exported to a CSV file, the Field text will be 
converted to normal text.  Information in the text will 
be the same as what was last displayed in the original 
table. 

• Explode: when used on any text object will convert the Field to normal text. 

• Find Replace: Find and replace will find Field information and replace it with normal text. 

• Manual override:  

o Fields in text objects can be manually overridden. 

o Fields defined in attributes that are set to be editable by the end user, can be 
manually changed during block insertion.  

• Convert Field to Text: converts a Field to regular text. Access by RMC in the associated 
text edit box and Click  “Convert Field to Text.”  

• Express tools: 

o BURST tool will change the Attribute Field text to normal text.  

o TXT2MTXT command will change Field text to normal text. 
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Exercise 4: Updating Fields 
Objective of exercise: Learning how to update Fields  

Estimated time: 5 minutes     
 

1. Open C:\DATASETS\GD12-1L \4-FIELD_TEXT.dwg (or continue in 
previous drawing) 

2. Save to see which Fields in the table will update. Hint: look at the seconds. 

3. Saveas C:\DATASETS\GD12-1L \yourname-FIELD_TEXT.dwg. The “date created” will 
update. The filename in the lower left corner updates to reflect the new name. 

4. Regen (RE) to see if the Table Fields will update. Hint: look at the seconds. 

5. Edit cell labeled “C:” as follows: 

a. Left click on Cell “C:” to select the cell in the Table,  

b. RMC and Click “Edit cell text.” This will open the text editor.  

c. RMC over the date Field and Click “Update Field.”  

d. Click OK to close text editor. 

6. Type UPDATEFIELD and select the Table to update. Only the “Date” Field will update. 

7. RMC in the graphics screen to open Options > User Preferences tab. Turn Off “Display 
background of Fields.”  Notice how Fields are displayed on the screen. 

8. Open the Mtext editor: 

a. Double click on the mtext to access the text editor.  Notice the highlighting still 
exists in the text editor.  

b. Close Open the Mtext editor (the text editor). 

9. Open the Dtext editor: 

a. Double click on the Dtext to access the text editor.  Notice the highlighting still 
exists in the text editor.  

b. Close the text editor. 

10. RMC in the graphics screen to open Options > User Preferences tab. In the lower left hand 
corner, turn On “Display background of Fields.” 

11. Close the Options dialog box.  
End of exercise 
 

Bonus 
12. Double click on the dtext (Papersize) to access the text editor.  

13. RMC on the Field and select “Convert Field to text.”   

14. Double click on the Mtext (Current tab) to access the mtext editor. Convert the text. 

15. Use the BURST command on the block attributes to change to text 

16. In the Table, RMC on a Field and select “Convert Field to text.”   

17. Explode the Table to convert the remaining Fields to text. 
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Veteran Players  (Blocks and Xrefs) 
Left handed or right handed hitters (The Attribute or Text Decision) 

When Fields are used in blocks they may be included as text or as attributes.  

When Text is better than Attributes: when you double click on the block to edit the 
information, the attribute dialog box will not include the text. This may reduce accidental overriding 
of the Field. You can set Mtext to wrap. This can be helpful when you may need information on 
multiple lines of text.  Example: the drawing title or subject may vary significantly in length. When 
multiple lines are needed the mtext will automatically wrap.  

When Attributes are better than Text: You can extract Attributes from the drawing in order to 
share drawing information. Attributes can display different values in multiple instances of the same 
block. Regular text does not have the flexibility to display different values in multiple instances of 
the same block. Attribute text will have a grip that can be selected, allowing for adjustments to the 
attribute text location without exploding the block. 

Handling Temperamental Players: (Results of using various Attribute settings ) 

Constant ON: Attribute Fields are fixed and therefore, not editable. The attribute will display a 
consistent value for every block that is placed in the drawing:  

• Attribute editing commands will not work on attributes set to constant.  

• The Find command will not affect attributes set to constant. 

• Information can still be extracted as an attribute. 

• Field information is less likely to be accidentally overridden. 

• Field information modified in Drawing Properties will update in the attribute. 

• Some Field values will not update if set as constant. (More on this later) 

Constant OFF (Default settings, including Preset and Verify): Attribute Fields with these 
settings can have different settings for each inserted value. 

• Attributes are editable by double clicking on them.  

• Advanced attribute editing commands such as EATEDIT will work on Attributes containing 
Fields.  

• Valued can be overridden in the Attribute editor. 

• Field data can be modified through the Drawing Properties. 

• Attribute information can be extracted modified when Saved to earlier software releases. 

• An attribute’s value can vary between blocks when multiple blocks are inserted into the 
drawing. (More this later) 

On the Road (Xrefs and Fields) 

A Field from an Xref will display the Field information in the host drawing (drawing it was inserted 
into). It will show the host file information whether inserted as Text with a Field or created in a 
block as an attribute with a Field. For Xref information that remains constant, use text without 
Fields. Fields that cannot be found will display as ####. This could happen if Custom Fields are 
defined in the source DWG file only.  
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Exercise 5: Fields in blocks 
Objective of exercise: understanding Fields and how they are used in blocks. 

Estimated time: 5 min 
 

1. Close any open drawings. 
2. Open C:\DATASETS\GD12-1L \5-Titleblocks.dwg 

 
3. Turn on the following Object Snaps: (command line: OSNAP) Endpoint, Node, Intersection. 
4. Insert the following blocks locate blocks as listed below. (Command line: INSERT or I) When 

inserting blocks use the defaults for scale and rotation. Accept default attribute settings. 
• TITLE-DEFAULT (locate in the upper left corner) 
• TITLE-CONSTANT (locate on the first point across the top) 
• TITLE-PRESET (locate on second point across the top) 
• TITLE-ATT AND MTEXT (locate on third point across the top) 

 
5. Double click on each of the blocks to add your initials into “Created by initials.” Note: The block 

with constant attributes will not let you modify it. 
6. Modify the following Drawing Properties under File > Drawing Properties  

• Summary tab: Add your name for Author  
• Custom tab: Add your company name and your address  

7. Close Drawing Properties and Regen (RE)  
 
8. Under File > Drawing Properties >  Summary tab: Modify Subject to a longer topic such as: 

“CREATING INTELLIGENT TITLE BLOCKS.”  
9. Close Drawing Properties and Regen (RE). Notice that the Field extends outside of the blocks 

except for the block where the summary was created as MTEXT. 
10. Save.  

End of exercise 
 
Bonus 

11. Make the “C-Size” tab current. 
12. Try exploding the titleblock in order to modify. Use Properties to determine what type of object 

the titleblock is. 
13. Make the “B-Size” tab current. 
14. Modify additional information in File>Drawing Properties.  
15. If time allows. In the lower right hand corner are some tools that could be used to start a 

titleblock. Copy the Attribute_Tag and Mtext into the desired locations on the grid. Indicating 
which you might use for the different situations. Each person or company may have a different 
solution. 
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Exercise 6: Xrefs, Fields and Blocks 
Objective of exercise: understanding Fields and how they are used in blocks 

Estimated time: 5 min 
 

1. Close any open drawings. 
2. Open C:\DATASETS\GD12-1L \6-xref-title.dwg 
3. Go to File >  Drawing Properties. Notice on the summary tab and custom tab, all 

information starts with XREF.   
4. Close Drawing Properties  
5. Close the file. 
6. Open drawing C:\DATASETS\GD12-1L \6-Titleblocks.dwg 
7. Insert>External Reference…  C:\DATASETS\GD12-1L \6-xref-title.dwg into the lower left 

hand corner. Use Scale = 1, Rotation = 0 
• Field data reflects information in current drawing  
• Fields that can not find related data are displayed as: ####  

End of Exercise 
 
Bonus 

8. Go to File > Drawing Properties > Custom tab.  
9. Create a new Field titled: (case sensitive and spelling is essential) 

•  “xref-company” and give the value any company name. 
• “XREF-ADDRESS” and give the value an address.  
• “XREF-CREATEDBY” and give the value any name. 
• Close the dialog box and Regen. 

 

Seventh Inning Stretch 
Fields in Context  

Most Fields will display the same information no matter where they are placed in a drawing. These 
Fields are considered not to be contextual. Some Fields are dependent on their environment. You 
may find that a value is different depending on which space it is placed in. Since plot information 
can be different per layout tab, the different layout tabs will display different values. Contextual 
Fields include: PaperSize, PlotDate, PlotOrientation, PlotScale and many of the Fields from the 
Sheetset Category. 

When contextual Fields are used in blocks they will only update if used as Attributes, not as text. 
The Attributes cannot be set to constant or the Fields won’t update. This behavior is due to the 
Field using the last cached value) 

 
 
 

Blocks: multiple instances of the same block will display the same 
identical data for the Field information inserted with text or mtext. 
Use attributes for contextual Fields 
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Exercise 7: Context Fields  
Objective of exercise: understanding Context sensitive Fields. 

Estimated time: 5 min 
 

1. Close any open drawings. 
2. Open C:\DATASETS\GD12-1L \7-Context.dwg 

3. Insert the block PAPERSIZE AND LIMITS. Accept default attributes. Note the paper size and 
max limits defined in the block. 

4. RMC for Options > User Preferences tab. Click Field Update Settings. In the Automatically 
update Fields, uncheck Regen. 

 
5. Left click on the “C-Size” tab to make it active.  

a. Insert block PAPERSIZE AND LIMITS.  
b. Note the paper size and max limits. 
c. Save.  Check if any fields update. 

6. Left click on the “B-Size” tab to make it active. 
a. Note the paper size and max limits. 
b. Save.  Check if any fields update. 

7. Left click on the “D-Size” tab to make it active.  
a. Insert block PAPERSIZE AND LIMITS.  
b. Note the paper size and max limits. 
c. Save.  Check if any fields update. 

8. RMC for Options>User Preferences tab. Click Field Update Settings. In the Automatically 
update Fields, place a check in front of Regen. 

End of exercise 
 
Bonus 

9. Left click on the “B-Size” tab to make it active.  
a. Save to update Fields.   
b. Plot to DWF into the C:\DATASETS\GD12-1L \ 7-Context_Titleblocks-B-SIZE.dwf 

10. Left click on the “C-Size” tab to make it active. 
a. Save to update Fields.   
b. Plot to DWF into the C:\DATASETS\GD12-1L \ 7-Context_Titleblocks-C-SIZE.dwf 

11. Left click on the “D-Size” tab to make it active.  
a. Save to update Fields.   
b. Plot to DWF into the C:\DATASETS\GD12-1L \ 7-Context_Titleblocks-D-SIZE.dwf 

12. Close all DWG files. 
13. Open Windows Explorer (RMC on Start at the task bar) browse to the DWF files. 
14. Double click on DWF files to view. 
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Popcorn, Peanuts and Crackerjacks (Linked, Objects, Sheet Sets and Other) 
Links 

Hyperlinks use the control key and click the object to jump to the link. Hyperlinks can be used to 
include additional documents into a DWG file.  

• Hyperlink; similar to using the HYPERLINK command on a piece of text;  

• Fields allow you to have multiple hyperlinks within one piece of text.  

• The text for a link in only a label. It won’t update if the objects name is changed. 

 

Insert hyperlinks dialog box: the hyperlink will be retained when published or plotted to a DWF 
file. This is controlled in the Insert hyperlink dialog box. The associated path of the hyperlink can 
be stored or the path can be set to relative.  

 
Existing file or web page: 
Link to a file on your local 
drive, the network or the 
Internet. 
View of this drawing: Link to 
model space, to any layout or 
to a named view, created with 
the VIEW command. 
E-mail address: When a 
hyperlink is used with e-mail, 
using the CTRL+Click on the 
Field will open a new e-mail 
file to send. The address and 
subject are already filled in. 
 

Objects 

Named objects: Fields can list names of blocks, dimension styles, linetypes, table styles, layers, and 
view names.  For currents settings use system variables; more on this later. 
 
Object: Select drawing objects to display the properties of the object. Properties are different for 
different types of objects just as they are in the properties dialog box. Use named object to add labels to 
an object.  

• Named Objects that are renamed will have the name updated in the Fields. 

• Use objects to define boundaries, allowing you to label the area and perimeter. 

• Many Object Fields can be used in blocks.  

• Fields can be grouped with blocks to make is easy to move the block and the text together. 
Groups can be toggled on and off with Control+Shift+A. 

• When on layout tab in paper space, you cannot select an object from the model tab. 
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Exercise 8: Linked and Objects 
Objective of exercise: Using Fields with hyperlinks and Objects 

Estimated time: 5 min 
 

1. Close any open drawings. 
2. Open C:\DATASETS\GD12-1L \8-Links.dwg 
3. Zoom in on the titleblock.   

4. CTRL + Click on each of the following:  
a. “Send e-mail.”  (Sign your name and send the e-mail or cancel out)   
b.  “Audio” listen to audio message. 
c. “Web” to go to the web page, then close it. 

5. Zoom Extents (Double click on mouse roller). 
6. In the “Layer Control” table CTRL + Click on each of the links. 
7. In Model space create a hyperlink to return to the layout “A-Sized.” 

a. Dtext: place on screen,  text height =  2”, rotation angle = 0. At the text prompt, RMC in 
graphics screen to access Insert Field. 

b. Field category: Linked,  Field name: Hyperlink 
c. Click, Hyperlink button. 
d. Link to: View of this drawing 
e. Select a view of this: A-Sized 
f. Click OK twice to close dialog boxes, finish placing the text.  

8. On “A-Sized” tab; Insert a label onto the viewport as outlined below.  (Turn on the VPORTS 
layer if not visible.) 

a. Start Dtext (DT): place on screen, text height =  .18”, rotation angle = 0. At the text 
prompt, RMC in graphics screen to access Insert Field. 

b. Field category: Object, Field name: Object 
c. In object type: Click the “Select object button” 
d. Click on gray rectangular boundary line that defines the viewport 
e. Property: Click custom scale, select any format.  
f. Click OK to close dialog box. Place the Field under the viewport. 

End of exercise 
 
Bonus 

9. In model space 
a. Insert > Field, Field category: Object, Field name: Object 
b. In object type: Click the “Select object button” 
c. Click on the gray polyline that outlines the room.  
d. Property: Click Area, select any format.  

10. Make a layer control link.  On the layout, turn off the border layer. Make a named view of the 
layout using the VIEW command. In the view dialog box, ensure that the setting “Store current 
layer settings with view” is turned on. In the layer control grid, add the view as a hyperlink. 

11. Complete the Detail Table with information as desired. 
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Sheet sets 

Sheet set related Fields are available when working with sheet sets. When working with sheet sets 
there are labels that can be automatically placed. Sheet sets labels are defined with Fields. 

Other 

DIESEL expression: DIESEL is Macro language. AutoCAD Help has additional information on 
DIESEL. For Diesel expressions calling out Xref or image files you may still want to use Rtext. 
Example:   $(xrefs)    $(images) 

Some Examples of DIESEL expressions: 

$(eval,"Current layer: " $(getvar,clayer)) 

$(edtime,$(getvar,date),DDD", "D MON YYYY) 

$(getvar, "dwgprefix")$(getvar, "dwgname") 

System variable  

Fields can call out system variable directly without the use of DIESEL.  System variables can be 
used to call out current variables, as the variables change the Fields update. 

 
Exercise 9: Sheet Sets, DIESEL, and System variables  
Objective of exercise: Using Fields with System variables. 

Estimated time: 5 min 
 

1. Close any open drawings. 
2. Open C:\DATASETS\GD12-1L \9-system variables.dwg 

3. Insert block system variables 
a. Change the variables ATTDIA, CMDDIA and FILEDIA  to 0.  Regen. 
b. Change the variables back to 1. Regen 

4. Double click on the orange date text in the lower left corner. 
a. RMC over the Field and Click “Edit Field.”  
b. Delete two Y’s to change “D MON YYYY” to “D MON YY”   
c. Regen  

5. Edit the Field text in the titleblock to view the Field settings. 
6. End of exercise 

Bonus 
7. Open the sheetset manager (command line: SheetSet) 
8. On the resource tab expand 8-Links.dwg 
9. Drag the view “Layers on” onto the current layout tab. 
10. Zoom to the “Project name and address” in the titleblock. 
11.  In the sheet set manager, on the sheetlist tab, RMC over the sheetset name “Autodesk 

University” 
12. In the menu click Properties 
13. Under sheetset custom properties fill in you company name and address. 
14. Close and Regen. 
15. Edit the titleblock Fields to see how they were created.  

 



 Field of Dreams in AutoCAD 

   20 

 
 

Game Highlights (Conclusion) 
Fields provide intelligent information linked into our drawings.  

 
• You can use Fields in Text and in Attributes.  
• You can use Text fields by themselves or nested into a block. 
• You can use Field to call out drawing properties information to be read directly. 
• You can use Fields to Automated text to: 

o Add date and time into blocks attributes or text.  
o Use Drawing properties to drive information on the drawing.  
o Hyperlink within the drawing or to other files. 
o Call out Named Objects in the drawing. 
o Call out object properties that will update as the drawing updates. 
o Place System Variables directly into the drawing.  
o Add DIESEL expressions to the drawing. 
o Create our own plot stamp or list plot information on the drawing. 
o Modify link provided in your Sheet Sets.  

• You need to manually update Fields with tools such as Save, Regen, Open, and Plot. 
 
You use Fields to add intelligence to your drawings. You can customize your drawing with titleblocks, 
blocks, tables, plot stamps, email links, web page links and much more. When you use Fields, the text 
information in the drawing stays current reducing errors and aiding in drawing consistency. 
 
 
Go get ‘em  and happy fielding! 
 
 
 
Colleen Klein 
colleen.klein@masterg.com  
Appleton, Wisconsin 
  
 

 

 

 




